FANDOM


Introduction

This guide will teach you how to make simple renders of Zoo Tycoon 2 downloads.These are useful when there are no pictures available or they are not suitable (too small, not very distinctive, etc.)

You will need the following programs:

  • A Zipping program - can be Winrar, Winzip or 7zip.
  • Nifskope.
  • Photoshop or other editing program that allows you to have a transparent background. You can get a free version of photoshop here.

It may look long but after you know what to do it will just take you about 1-2 minutes to make each render.

Part 1 - Zipping Program

You will need to download the content you want to make renders of. When you have the .z2f, use your zipping program to extract it wherever you want so you can access the files inside. You will see many folders and subfolders. If making renders for animals, go to entities > units > animals > AnimalName. If making renders for objects, go to entities > objects > foliage/rocks/scenery etc. > ObjectName. When you are in the animal or object folder, you will see many different files. We will need Animal/ObjectName.nif and Animal/ObjectName.dds .

Part 2 - Nifskope

Step A - Setting up Nifskope

You will onyl need to do this the first time, as the settings will be saved.

Open the .nif file using Nifskope. Now first we will configure the program like we need. Go to View > Block List and check it. Then in View > Block Details, uncheck it like this:

Making Renders1

Then go to Render and uncheck Perspective, Draw Nodes and Draw Axes:

Making Renders7

Then go to Render > Settings... > Color and use your right click button on "background". You will see a list of many colors, go to the end of that list and click on Hex Edit.... On the three squares write: df, dc and c3 respectively. This way your nifskope background color will be the same color as the wikia background, which is helpful for semi-transparent models (windows, insect wings, fur, etc).

Now we're done setting up the program. Next is preparing the model.

If the model looks fine as it is, go ahead to the next step.

Step B - Preparing the model

Now it's probable that your model is not looking quite right.

  • If your model looks all white, click on it and then go to the Block list. Expand the pluses until you see a purple flower icon, click on it and browse for the Animal/ObjectName.dds that should be inside the same folder as the .nif .
Making Renders6
  • If your model still has white parts, for example teeth, whiskers, mane, wood and such, click on them as in the step above. Look at the name after the purple flower icon, and then click on the purple flower and browse the folders you extracted from the z2f. The files you are looking for will probably be in a folder called shared, inside entities > units > animals > shared, and the same for rocks, foliage, buildings, etc. Note that some may be in other of the designer's work, or original game files, in which case you would need to go to your Zoo Tycoon 2 game folder to find them.

Step C - Positioning the model

Once the model is looking like it should, move it around until you like how it looks and take a screenshot with the Print Screen key. Things to note:

  • You can use the left/main click to rotate the model, the right/secondary button to zoom in and out, and the middle mouse button to move it around without rotating or zooming.
  • You can use Ctrl + F9 to save a certain position, this way you will get the same view again when pressing F8, and all models will open in that same position by default, which is useful when making renders of several models.
  • Try to zoom as much as you can while the model still fits the screen and looks right. Some downloads may have a blurrier texture and don't look that good up close, while some have a very detailed texture and look great up close. The wikia will resize the picture so you don't need to worry about it being too big, and this will allow people to take a closer look at the download once the page is made.
  • Remember we use square pictures at the wikia, so try to pose the download so that it looks right without too much space to the sides or the top and bottom, if possible.

Step D - Variants

You may skip this step if the download you are screenshoting does not have variants. I don't recommend adding variant renders for animals with little variation (ex. a brown animal which has a lighter brown variant and a darker brown variant). It's more useful when the variants are a different color, like a white tiger or a black wolf. To make variants just click on the model and then the flower icon below, and select AnimalName_1.dds, AnimalName_2.dds, etc. Take care not to move, rotate or zoom the model while doing this, as it will cause an annoying "trembling" effect while displaying the variants.

Part 3 - Image editing program

After taking your screenshot, open up Photoshop or another image editing program that lets you crop out the background. This explanation will be photoshop related but it should be similar with other program.

Making Renders 7

Location and icons of the Magic Wand and Selection Tool in the Photoshop toolbar.

Type Ctrl + N to open a new tab and make sure the background is set to "transparent", and then Ctrl + V to paste the screenshot. Then use the Magic Wand to select the background. While doing this, set Tolerance to 0 and uncheck "Contiguous". "Anti-aliasing" can be checked or unchecked, as it makes for softer borders but the difference is not very noticeable inside the wikia. Uncheck it if you have many alphas, like tree leaves or fluffy fur, as it could make them look bad.

When the background is selected type Ctrl + X to cut it. Now that we have a transparent background, select around the model with the rectangle Selection Tool (make sure that all the model is inside the selection, and none of the interface) and copy it with Ctrl + C.

Now click Ctrl + N again, but look at the proposed width and height. Change the smaller amount so that both are the same number, for example if you have 230x510, change it so it's 510x510, then click accept. Now paste the model with Ctrl + V. There may be some transparent space left around it, but leave it like it is, since we want a square image. Use Ctrl + S to save the picture as .png and you're done.

Repeat the last step if you have multiple models and/or variants.

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.